Serious SharePoint

So you have setup your Metadata Service Application (including the content type hub url), you configured the proxy (making sure to check the consume content type checkbox), and you have published your content types!  So everything is working right?  Wrong. What site did you use as the site collection root?  If custom, what was the…

Read More

Detail:  Following databases have large amounts of space allocated on the disk but not in use. This may be due to recent deletion of data form the database, or because the database has been pre-grown to a larger size. This database will take up a larger amount of space on the file system unless it…

Read More

Detail:  A default zone url is pointing to the machine name of a web front end.  Since this installation has more than one web front end, this can result in a variety of errors including incorrect links and failed operations. Solution:  A unique domain name will be created for the web application and once the…

Read More

Detail:  InfoPath Forms Services is not functional on the following Web applications because there is no service connection configured for the State Service. Solution:  A State Service Application has to be created and associated with the active web applications.  This will be done via PowerShell as follows: Create a new state service application: New-SPStateServiceApplication -Name…

Read More

Detail: (Truncated due to length) [MissingFeature] Database [WSS_Content] has reference(s) to a missing feature: Id = [fc5e2840-0b48-42eb-9ad7-076f5add58ad]. The feature with Id fc5e2840-0b48-42eb-9ad7-076f5add58ad is referenced in the database [WSS_Content], but is not installed on the current farm. The missing feature may cause upgrade to fail. Please install any solution which contains the feature and restart upgrade…

Read More

This error occurred in SharePoint Designer 2010 when attempting to edit a masterpage.  Like many errors with SharePoint 2010, this is related to Alternate Access Mappings.  The server was being connected to by its short form url of http://site.  If connected via the long form, http://site.domain.extension, it would work with issue. To permanently resolve the…

Read More

You are prompted to download and save these documents.  After a bit of trolling the internet, I found the link below.  Apparently it is a Central Administration setting.  To resolve the issue we need to set Browser Handling to Permissive. Open Central Administration Click “Manage Web Applications” under “Application Management” Highlight the web application experiencing…

Read More